ADSL and Linux (answer) - Linux, Mac and other operating systems - HWzone Forums
Skip to content
  • Create an account
  • About Us

    Hello Guest!

    Please note - in order to participate in our community, comment and open new discussions, you must join as a registered member.

    Our members enjoy many advantages, including the ability to participate in discussions, enjoy raffles and promotions for members of the site, and receive our weekly content directly by email.

    Do not like being harassed by email? You can register for the site but do not submit your registration to the weekly email updates.

ADSL and Linux (answer)

Recommended Posts

Well, later onמדריך On the router And to the questions that were addressed to me I checked the subject, and it turns out that the demon is not so bad :)):

First of all I strongly recommend reading the HOWTO-ADSL-BEZEQ Of Molix.

I installed on Linux system Mandrake 8.1 at my friends Sman (Who by the way published a question on the subject p; am

p; num = 1002025850 '> here on the site as well as in the Rotter forum and without since) although I do not think there will be a big difference between the different distributions.

First of all - pppd, if you install this standard installation it should be installed, and in a reasonable version. Test: pppd --version, with Mandrake 8.1 comes 2.4.1 version that definitely provides.

Second - pptp. As I mentioned in the guide on the router, the reason it is "complicated" here in Israel is because Bezeq chose to combine the two PPTP (this combination carries advantages and disadvantages, its disadvantages far outweigh the advantages in my opinion - did you know that every bit of information is also sent a VPN authentication bit?). I must note that in this context Linux is much simpler than Windows (if we ignore the graphical interface), the pptp command handles both the transfer and the network .

First thing I checked the version: pptp will display a version message - Mandrake 8.1 it will display 1.0.2. I tried to activate the connection with him and it did not succeed, poor thing: there is no choice but to update to the latest version (1.0.3) and the compatible (for Bezeq and modems of Orkit and Alcatel) HERE (Tar.gz file, with source code C).

After you open it, it may seem strange to you (if you're new to the world of Linux) that there is no executable file - this is because most Linux programs, and all the programs that I come across as tar.gz come as source code that requires compilation, . By the way, this remains much more flexible both for developers and end users, but requires adaptation to what.

Now you have to edit the Makefile file (to remember) and make sure that the pppd path is correct (pptp uses pppd which is the Linux connection program with Point-to-point, such as the Internet), after you have done this, run Make to compile the C code into an executable file.

If you find that the Make command is not installed (while you are working as a shred), as I did, it must be installed. I did this with the help of a nice tool in Mandrake called SoftwareManager (all to my memory). Then install a C library (I think we need gcc), and then everything will work.

The command created a number of executables, one of which is PPTP, now we will test it as: pptp /. - God /. Make sure he runs it from the library where they are now, I do not remember exactly the result but write down somewhere somewhere in 1.0.3 (very good).

The next step was to flip the new file in the old place, so that every time the system called pptp it would be activated. I do not remember exactly where the old file was, but I think it's in / usr / bin (the size of the file is huge because of the huge amount, the new file swelled to more than 130 Kay when the old one was around 30). The pptp_callmgr which I also compiled (again from memory), I'm not sure if it's necessary but I have not tried without it.

The next step was to check the manual in a similar way to a charm:

ifconfig eth0 netmask mtu 1500 To give the card (eth0) values ​​these values.

Then this command:

pptp debug user @I remotename " RELAY_PPP1"

defaultroute mtu 1452 mru 1452 noauth

* Of course I have previously edited the / etc / ppp / pap-secrets and / etc / ppp / chap-secrets files as explained in the manual.

And, surprisingly, it was connected, by the way, in order to disengage run the following commands (again, all the credit of course to the guide):

ifconfig ppp0 down and killall pptp.

But this is not the end of the work, it is not possible to run this command every login and even with a script the whole thing is quite cumbersome, the whole thing was for testing only ...

I was determined to use it with the dialer (if you can call it that) the graphic of Mandrake.

First go into the Control Center. Where to go to the grid and set as follows:

Select Configure , Do not catch me with the word) when it offers automatic discovery - No (In the beginning, we'll get to it soon). Then LAN and ADSL, when this is very unreliable information (when it comes from me because it's only from memory, but we'll try what we can) ..

At first it displays an ADSL menu with general details of name (connection), DNS, username and password. Enter all the details and please do not forget the username: @I .

Then it displays a menu of the LAN: AIPI: (I do not remember what else is there, then NEXT) was diverted: "RELAY_PPP1" (this is indeed a profit and of course the riley after the EIP - it may be turning over here) .

When he asks where to connect, tell him to LAN, then he will suggest running it every session (tell him No - After all we do not know if it works yet and his constant search of the network will slow down is very Its operation, from experience) and say that it needs to restart the network (yes), then do Apply Turn off and restart the modem (always helps :)) And try to connect. It will not work.

Now do it again only when it offers the automatic setting at first you will answer Yes, Now in the section of the ADSL if it is set correctly it should show you the vendor's DNS, so the c-l-h-h, continue to the end (including the Apply) and you are done (!!!).

That's it, so I did and it worked, if anything had any questions No Address that NO My ADSL or access to it (it lives 30-40 minutes from me), a lot of credit comes to Molix and its list of contributors and my friend that Chelts did everything, so good luck to everyone.

: Has:

Link to content
Share on other sites

I had more to write here but it was limited in place and all the time demanded that I cut short, brash ...

In short - comments:

* It may not work through the settings of Mandrake because they do not meet the special requirements (such as Alcatel's "bugs") etc.

If so, there is no choice but to do a script or edit the scripts Mandrake uses (I do not remember where it is but it's not a problem to find).

** Everything I wrote I wrote from memory. I still do not have Mandrake 8.1 (another 26 hours I finish downloading it on my 56 modem, this is to prove that I am able to download 2 gigabytes without the help of the "fast" authors), and I have no ADSL at all.

*** I had more comments but I've forgotten them designers that it did not let me post in the previous post.

Come on, Lila Toph and good luck.

: Has:

More comments:



* * *

* *


In the section of the sketch in the graphic tool of Mandrake:


It's with quotation marks (again in my memory, and I write it after more than a month or so).

Link to content
Share on other sites

TheWizard You are a chutzpah  : bash: I 've done everything. ???  : nono: I just wrote what you said to me, it was the first time I actually did anything in Linux except to look at your router  : Lol: So stop pretending to be modest here.

Anyway, we both did a great job without the instructor Because those who recommended it did not give us a link  :P And yet we succeeded and grew up.

Anyway I wanted to take advantage of what it is to say thank you very much for all the support and help, yes many friends like you

Link to content
Share on other sites

You as if you know there is a step-by-step tutorial on the site , Yes?

You're already the second one to say it (one said Bruter, he told me Sman), And without a link.

Please note that I searched for this manual and did not find it - and I do not believe it (on the basis of 'you worked and found - believe').

So getting a link for a change will be very refreshing, thanks.

: Has:, Wise.

Link to content
Share on other sites

TheWizard You are a chutzpah

Your brother
I did everything? ???  : nono: I just wrote what you told me

So stop pretending to be modest here.

You took the words out of my mouth.
Anyway, we both did a great job without the instructor Because those who recommended it did not give us a link  :P And yet we succeeded and grew up.

: bigghumpup: what's true - true: bigghumpup :.
Anyway I wanted to take advantage of what it is to say thank you very much for all the support and help, yes many friends like you

This time you really exaggerated pruning ...: - [(supposed to be blushing ....).

And of course, right back at you - yes, they will multiply like you friends: grinangel:

bye, : Has:

Link to content
Share on other sites

Link? Did you hear Link? I heard a link, no problem:

& pageid = 1629

Really something that damage these, can not write a more bad guide even if they try ... :P

First of all the version of PPTP name is old.

Second, to whom exactly the guide is intended ????????? - Is it for those who understand Linux or anyone who comes across a name for the first time ...

If this is for those who understand HOWTO Molix's much better, fits and explains.

If it is for those who follow

step by step
זה Will not work, But not without changes and understanding in Linn, so we return to the first point ("for those who understand ..." above).

So I think the explanation I wrote hereof course ה HOWTO (Or "the dialer") - not that I'm in favor of it, but I think it's a good idea, But it certainly would have helped most people.

: Has:

Link to content
Share on other sites

  • 3 weeks later ...


This discussion has been archived and new comments can not be added.

  • Latest news

  • Buzz-Zone: Everything hot on the net

  • Popular now

  • Create new ...

At the top of the news:

new on the site

Now it's official: the comeback of the GeForce RTX 2060

Now it's official: the comeback of the GeForce RTX 2060

The intermediate model from the Turing generation adopts the number of active units in its refreshed super version, equipped with double the volume of graphic memory - and goes out to provide a solution to some of the constant demand for more and more video cards