A broken video card was sent for repair and returned more broken. HWzone Forums
adplus-dvertising
Skip to content
  • Create an account
  • About Us

    Hello Guest!

     
    Please note - in order to participate in our community, comment and open new discussions, you must join as a registered member.

    Our members enjoy many advantages, including the ability to participate in discussions, enjoy raffles and promotions for members of the site, and receive our weekly content directly by email.

    Do not like being harassed by email? You can register for the site but do not submit your registration to the weekly email updates.

A broken video card was sent for repair and returned more broken.


Tax1 Dr1v3r
 Share

Recommended Posts

A week ago I received the video card I sent for repair a month ago. When I turned it on the first day it worked fine, even though it was noisy and the computer was hot, which it was not before.

 

The day after I started getting artifacts every time I ran a game or software that adopts the video card, and it also started bringing me the blue death screen of 10 (the reason I sent it for repair in the first place)

 

I suspect they sold me a broken video card.

 

I no longer trust the store I bought the video card from, and want my money back. 

 

I bought the computer with the video card at the end of 2019.

 

Picture from yesterday.

 

How do I demand a refund from them?

 

 

 

 

IMG_20201103_175725.jpg

Link to content
Share on other sites

  • 5 weeks later ...

I brought an update to TMS once again the patch for repair: worked for a few days and then the problems came back again. Now games do not even turn on and even if they do turn on then after a few minutes they turn off, I did a stress test for a video card and found that it does the problems. That's the part I brought them.

 

If one of the TMS employees sees this, let him talk to me. I paid you NIS 10000 from the best of my money. In order not to encounter such problems and in the meantime I have been breaking my head with this part for 3 months now. I brought it in for repair twice and nothing was repaired.

Link to content
Share on other sites

Quote of Tax1 Dr1v3r

I brought an update to TMS once again the patch for repair: worked for a few days and then the problems came back again. Now games do not even turn on and even if they do turn on then after a few minutes they turn off, I did a stress test for a video card and found that it does the problems. That's the part I brought them.

 

If one of the TMS employees sees this, let him talk to me. I paid you NIS 10000 from the best of my money. In order not to encounter such problems and in the meantime I have been breaking my head with this part for 3 months now. I brought it in for repair twice and nothing was repaired.

@ Kirill-TMS

Link to content
Share on other sites

Join the discussion

You can then join the discussion and then join our community. If you already have an account with us, please Log in now To comment under your username.
Note that: The comment will appear to the surfers after approval by the board management team.

guest
Add a comment

×   The content pasted is with formatting.   Remove formatting

  Only 75 emoji are allowed.

×   Your link has been automatically assimilated.   Show as regular link

×   Your previous content has been automatically restored.   Clear all

×   You can not paste images directly. Upload or insert images from URL.

 Share

  • Latest news

  • Buzz-Zone: Everything hot on the net

  • Popular now

×
  • Create new ...

At the top of the news:

new on the site